After monitoring the situation, we can confirm that email delivery is stable and the incident is fully resolved. The disruption was caused by rate limiting on our email service provider's side. As a result, all outgoing emails were blocked from being sent, including donor transactional emails and account-related emails to Dashboard users.
Our team worked closely with our email service provider throughout the incident to identify and resolve the issue. Emails are now sending normally, and emails held during the disruption will be delivered over the next 1–2 days. All platform functionality remained fully operational throughout the incident — only email delivery was affected.
We apologize for the inconvenience and thank you for your patience.
Resolved
After monitoring the situation, we can confirm that email delivery is stable and the incident is fully resolved. The disruption was caused by rate limiting on our email service provider's side. As a result, all outgoing emails were blocked from being sent, including donor transactional emails and account-related emails to Dashboard users.
Our team worked closely with our email service provider throughout the incident to identify and resolve the issue. Emails are now sending normally, and emails held during the disruption will be delivered over the next 1–2 days. All platform functionality remained fully operational throughout the incident — only email delivery was affected.
We apologize for the inconvenience and thank you for your patience.
Monitoring
Email delivery has been restored. The disruption was caused by rate limiting applied by our email service provider, which prevented all outgoing emails from being sent. New emails are now going out as expected. All emails held during the disruption will be delivered — most should arrive shortly, with the full backlog cleared within the next couple of days.
We're monitoring closely and will post an update once we've confirmed the system is back to normal.
Identified
We are continuing to work closely with our email service provider to lift the current restrictions and resume email delivery.
While a confirmed ETA is not yet available, we will provide a further update as soon as there is any progress.
Identified
We continue to maintain close communication with our provider. Their internal engineering teams are treating the issue as a priority to expedite a resolution.
We will keep you informed and share an update as soon as we receive more details.
Identified
We are still working with our email service provider to resolve the issue affecting email delivery.
We will share another update as soon as more information becomes available.
Identified
We are still working with our email service provider to resolve the rate limiting issue.
We don't have an ETA to share yet, but we'll post an update the moment there is any progress.
Identified
We are still working with our email service provider to resolve the rate limiting issue. All emails queued during this period will be delivered once the issue is resolved.
We'll share another update within one hour.
Identified
We have identified the root cause of the email delivery disruption. The issue originates with our email service provider and is related to rate limits on their side.
We are working with our provider to resolve the issue and will post another update within one hour.
Investigating
We have identified an issue affecting email delivery across our platform. No emails are currently being sent, including transactional emails to donors and account notifications to dashboard users. The donation process and all other platform functionality are operating normally — only email delivery is affected.
Our team is actively investigating the root cause. We will provide an update as soon as we have more information.