Google Pay functionality has been fully restored. Google Pay donations are now processing normally, with error rates returned to baseline levels.
The incident was caused by a recent configuration change affecting Google Pay processing, which has now been corrected. New Google Pay donations were unable to process during the affected window. Existing recurring donations continued to process normally and were not impacted. All other donation methods remained fully operational throughout the incident.
We sincerely apologize for the disruption and appreciate your patience.
Resolved
Google Pay functionality has been fully restored. Google Pay donations are now processing normally, with error rates returned to baseline levels.
The incident was caused by a recent configuration change affecting Google Pay processing, which has now been corrected. New Google Pay donations were unable to process during the affected window. Existing recurring donations continued to process normally and were not impacted. All other donation methods remained fully operational throughout the incident.
We sincerely apologize for the disruption and appreciate your patience.
Monitoring
The hotfix has been successfully deployed, and our engineering team is actively monitoring Google Pay transaction processing to verify stability. At this time, we are continuing to observe system behavior before confirming full resolution. Other payment methods remain unaffected.
We will provide another update as more information becomes available.
Identified
We are currently experiencing an issue causing Google Pay transactions to fail. Donors attempting to complete one-time donations using Google Pay may be unable to do so, and recurring Google Pay charges are also impacted. Other payment methods remain fully operational.
The root cause has been identified and traced to a recent change affecting Google Pay certificate handling. Our engineering team is actively rolling back the change as part of a hotfix deployment.
We will provide another update once the rollback has been completed and Google Pay transaction processing has been fully restored.