The incident has been fully resolved, and all platform functionality has returned to normal. The issue was caused by a connectivity disruption with our CDN provider, which has now been addressed and mitigated.
We recognize the impact this incident may have had on your operations and donor experience, and we sincerely apologize for the disruption. Thank you for your patience while we worked to restore service.
Posted Mar 28, 2026 - 10:34 EDT
Monitoring
All services are now operating normally, including the Checkout Modal, Campaign Pages, and Elements. We are continuing to monitor the platform to ensure stability.
We will provide a final update once monitoring is complete.
Posted Mar 28, 2026 - 10:21 EDT
Update
The issue affecting Elements has been resolved, and they are now operating normally. We are continuing to work on resolving the remaining issues impacting the Checkout Modal and Campaign Pages. Some users may still experience loading issues while remediation efforts are ongoing.
We will share further updates as they become available.
Posted Mar 28, 2026 - 10:09 EDT
Update
We continue to work on resolving the connectivity issue with our CDN provider affecting the Checkout Modal, Campaign Pages, and Elements. Some users may still experience loading delays or difficulties opening the checkout window while remediation efforts are ongoing.
We will provide further updates as more information becomes available.
Posted Mar 28, 2026 - 09:23 EDT
Update
We have identified the cause of the connectivity disruption with our CDN provider affecting the Checkout Modal, Campaign Pages, and Elements. Our engineering team is actively working to resolve the issue and restore normal operations. Some users may continue to experience loading delays or difficulties opening the checkout window while remediation efforts are in progress.
We will provide the next update within 30 minutes.
Posted Mar 28, 2026 - 08:57 EDT
Identified
Our monitoring systems have detected an issue affecting the Checkout Modal, Campaign Pages, and Elements. The issue appears to be related to a connectivity disruption with our CDN provider, which may cause loading issues or prevent the checkout window from opening for some users.
Our engineering team is actively investigating and working to restore normal functionality. We will provide the next update within 30 minutes.