Database performance degradation

Incident Report for Fundraise Up

Resolved

The database performance issue has been resolved, and platform operations have returned to normal.
The incident was caused by application behavior that unintentionally generated excessive load on the database, resulting in degraded service across multiple components. The contributing processes have been stopped, and system stability has been fully restored.

Donors and customers should no longer experience issues. We will continue to monitor the platform closely and conduct a thorough internal review to help prevent similar incidents in the future.

Thank you for your patience.
Posted Feb 18, 2026 - 09:47 EST

Update

The root cause of the database performance degradation has been identified. Our engineering team is actively implementing remediation measures to restore full platform performance. Users may continue to experience degraded performance while corrective actions are in progress.

We will provide the next update shortly.
Posted Feb 18, 2026 - 09:17 EST

Identified

Our monitoring systems have detected a database issue impacting platform performance. Customers may experience increased latency, intermittent timeouts, or temporary unavailability of certain features.

Our engineering team is actively investigating and working to restore full service stability as quickly as possible. We will provide an update within 30 minutes.
Posted Feb 18, 2026 - 08:52 EST
This incident affected: Dashboard, Donor Portal, and Checkout.