Checkout Modal and Campaign Page loading issues

Incident Report for Fundraise Up

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 07:33 EST

Update

The issue affecting Checkout Modal and Campaign Page loading has been resolved, and services are operating normally. The root cause was related to a data synchronization issue between backend systems. The issue has been corrected, and platform stability has been restored.

All services are operating normally. We will continue to monitor the platform and conduct a review to help prevent similar incidents in the future. Thank you for your patience.
Posted Feb 27, 2026 - 07:29 EST

Monitoring

The fix has been successfully deployed, and Checkout Modal and Campaign Pages are loading normally. We are continuing to monitor platform performance to ensure stability. If you continue to experience any issues, please contact our Support team at support@fundraiseup.com.

We will provide a final update once monitoring is complete.
Posted Feb 27, 2026 - 07:20 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 27, 2026 - 06:57 EST

Identified

We are currently experiencing an issue where the Checkout Modal and Campaign Pages may fail to load for a subset of users.
The root cause has been identified, and a fix is actively being deployed. Some users may continue to experience loading issues until deployment is fully completed.

We will provide the next update within 30 minutes.
Posted Feb 27, 2026 - 06:56 EST
This incident affected: Checkout.