Delay in Data Display
Incident Report for Fundraise Up Status
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 10:46 EDT
Monitoring
The issue has been resolved. The system is fully operational.
Posted Apr 18, 2024 - 10:44 EDT
Identified
Donations are displayed with a delay in the Dashboard under Insights and Donations tabs.

All Checkouts and Campaign pages are functioning correctly. Receipt emails are also being sent. We will keep you updated on the progress of fixing the issue.
Posted Apr 18, 2024 - 10:32 EDT
This incident affected: Dashboard.