PayPal payments are currently unavailable

Incident Report for Fundraise Up Status

Resolved

PayPal has resolved the issue, and all payments are now processing successfully.

Any delayed recurring payments will be retried over the next few hours.
Posted Aug 01, 2025 - 11:06 EDT

Monitoring

We’re seeing that the issue is almost resolved — most payments are now going through without problems. A small percentage of payments (less than 10%) may still encounter errors.
Posted Aug 01, 2025 - 10:50 EDT

Identified

We’re experiencing an issue with PayPal and payments through PayPal can’t be completed right now due to an incident on their side. You can check PayPal’s status page for updates: https://www.paypal-status.com/incident/production

All recurring payments will be retried once PayPal resolves the issue.
Posted Aug 01, 2025 - 08:40 EDT
This incident affected: Checkout.