Cloudflare has confirmed that their global network is operating normally. We have verified that all Fundraise Up services are fully functional and stable.
This incident is now resolved.
Posted Nov 18, 2025 - 12:53 EST
Update
Platform Fully Operational Monitoring: While Cloudflare reports they are still mitigating residual issues on their end, we can confirm that all Fundraise Up services are currently operational.
Traffic levels and transaction processing have returned to normal across the platform. We will maintain our Monitoring status until the vendor incident is fully resolved to ensure stability.
Posted Nov 18, 2025 - 11:03 EST
Update
Cloudflare has implemented a fix, and we are currently observing a recovery in traffic levels across our platform.
Services that were previously impacted, including Modal Checkout, Elements, Campaign Pages, and the Dashboard, are coming back online and processing requests successfully.
We will continue to actively monitor system performance and error rates to ensure full stability before marking this incident as resolved.
Posted Nov 18, 2025 - 09:47 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 09:45 EST
Update
Service Impact Clarification
We want to provide specific clarity regarding the scope of the current Cloudflare incident and its impact on Fundraise Up services.
Recurring Donations: Scheduled recurring payments continue to be processed successfully.
Transactional Emails: Donation receipts and system notifications are sending normally.
API & Integrations: REST API endpoints and data syncs remain operational.
Currently Unavailable (Frontend & Access): Due to the Cloudflare edge network outage, access to user-facing interfaces is currently blocked. This affects:
New Donation Intake: Modal Checkout, Elements, and Campaign Pages are failing to load.
Platform Access: The Fundraise Up Dashboard and Donor Portal are currently inaccessible.
We are monitoring Cloudflare’s recovery and will confirm as soon as these interfaces are restored.
Posted Nov 18, 2025 - 09:35 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 09:19 EST
Update
We are actively monitoring a service disruption caused by a major Cloudflare outage. Some users may continue to experience intermittent errors. Cloudflare powers traffic for millions of websites, so the impact is broader than Fundraise Up and affects a significant portion of online services globally.
We will provide an update when we see material improvement.
Posted Nov 18, 2025 - 08:01 EST
Update
We are currently seeing partial recovery of the service and continue to monitor the situation.
Posted Nov 18, 2025 - 07:29 EST
Monitoring
The root cause of the incident has been identified as Cloudflare edge network disruptions. We are now actively monitoring all affected systems to observe stabilization and ensure services return to normal.
We are committed to keeping you informed and will provide a full incident report once all systems are stable.
Posted Nov 18, 2025 - 07:11 EST
Investigating
Our monitoring system has detected an issue affecting Fundraise Up. Users may experience internal server errors due to a Cloudflare disruption (https://www.cloudflarestatus.com/incidents/8gmgl950y3h7). Our engineers are currently investigating the precise impact and will share updates soon.
We’ll provide another update within 30 minutes.
Posted Nov 18, 2025 - 07:09 EST
This incident affected: Dashboard, Donor Portal, Elements, Checkout, and Rest API.